yum install from epel rxvt-unicode.i686 on(old) centos6 32bit does not have ISOi14755 mode

noj llimah nollimahere at gmail.com
Mon Jun 19 19:06:38 CEST 2017


Dear maintainers,

First, if the following inquiry should actually be addressed to the
maintainers of EPEL package rxvt-unicode.i686, please let me know so that I
don't waste anyone's time.


__ my attempt at troubleshooting__
I have an issue with the installed rpm for the rxvt-unicode.i686 package in
that it simply will not engage the ISO 14755 mode at all. In
Xdefaults/Xresources I have set
URxvt.iso14755: True
URxvt.iso14755_52: True

but I am not greeted with the familiar 'ISO 14755 Mode' text on the
terminal prompt like I am in my 64bit Lubuntu distribution.

I am unfortunately stuck with the 32bit CentOS distro (vanilla ISO with
gnome desktop) for work purposes and I need to be able to enter unicode
characters on the terminal prompt for testing ICU's C++ libraries for work.

I have tried input methods 'ibus', 'x compose table', and also tried making
sure I have a working compose key. But nothing is working to trigger the
ISO14755 mode, regardless of whether I have these keyboard details turned
on or off.

I have also verified that I have all locale's available to me and that they
match up with my ubuntu distro's locale settings with `locale` and `locale
-a` commands on both machines.

The environment variables that are set by the urxvt terms are definitely
present and correct and I've read (practically) everything in
https://linux.die.net/man/7/urxvt256c-ml with no success.


___my actual questions________________
So, what I'm wondering is whether you know or could imagine that the EPEL
package rxvt-unicode.i686 was compiled without ISO14755 support? if so, is
there any way for me to get a hold of the source so that I can build it
myself? I've been trying to find the source code for the project so that I
can build it myself with the --enable-everything flag but I cannot find it
easily online.

Or am I missing something basic, mis-read something, or am just using an
un-supported configuration?


Thanks so much for your time!
Best,
-Jon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schmorp.de/pipermail/rxvt-unicode/attachments/20170619/cc4857f8/attachment.html>


More information about the rxvt-unicode mailing list