rxvt-unicode and the Powerline symbols

Rakulenko A. me at rakul.info
Sat Jan 9 02:04:50 CET 2016


Hi, everybody! I use rxvt-unicode aka urxvt and i actually like it very
much. This is important, because it means that i shan't accept switching
to another terminal emulator program as an option.
I want to try a certain oh-my-zsh color scheme, which requires my
terminal, my font, my X server, etc to support this exact Unicode
characters:

  ±  ➦ ✘ ⚡ ⚙
 "\ue0b0 \u00b1 \ue0a0 \u27a6 \u2718 \u26a1 \u2699"

And here, innocently enough my journey begins.
I was forewarned by the author of the color scheme (theme) about the
font requirements in the description.
So i read about what it is and it turns out, that everybody talks about
that as a "Powerline font", or Powerline character, if in particular.
So to get these "the Powerline" fonts on your average gnu/Linux system
you can use one of the following paths:

1. You can download a ready-to-go font from 9k+ places in the web, put
it into your ~/.fonts ,
then fc-cache -vf ~/.fonts a little
and try your font like this : printf '\33]50;%s\007' "xft:Terminus,
xft:DejaVuSans, xft:Noto Sans"
(this is urxvt configuration. Whole this post is about urxvt.)
Or you may edit your .Xresources file, xrdb -merge ~/.Xresources and
rerun your terminal.

2. You can somehow patch your existing font into supporting "the
Powerline" characters, but i didn't actualy try that, as i read also
that this is a deprecated method and you should not use it.

3. You can use urxvt chain-loading feature and have only one, single
font with "the Powerline" characters only (which do exist irl).
Then you specify font for urxvt like i did ("xft:Terminus,
xft:DejaVuSans, xft:Noto Sans") and in that case urxvt would search the
character to display in Terminus first, then (if not found) in
DejaVuSans, and then in Noto Sans.
//If you are reading this post in awe, hoping that your problem is the
same as mine - yes, these is the combination of fonts, which actualy
worked for me, but this is not the solution. It gives five out of seven
of the characters thou.

4. You can use the fontconfig magic, having the magical font from
previous variant.
(described here:
http://powerline.readthedocs.org/en/master/installation/linux.html)
And this is often remarked to as the latest and best solution to the
problem.
I think, that in gentoo (i use gentoo) it is done this way. There is a
ebuild media-fonts/powerline-symbols , which i think does exactly that.

As you might already have guessed, all these methods failed in my case.
They gave various results. but the average looked like that:
http://i6.5cm.ru/i/DQOz.png
It gives three out of seven symbols.
However, if you use one of 1st, 2nd or 4th methods (and you should use
the fource, em, Luke) .. and then as in 3rd method - use urxvt font
combination
feature to stack missing "the Powerline" characters.
And yes, here the "xft:Terminus, xft:DejaVuSans, xft:Noto Sans", amen
font combination gives you best i got so far - 5 out of 7
(http://i6.5cm.ru/i/sct0.png)

To prove that i have installed the fonts properly and my xft, linux,
xorg, pc and eyes are capable of anything needed for the task, i have
this screenshot of
Kopete in parallel to urxvt in the middle of my struggle:
(http://i6.5cm.ru/i/CRD5.png).
As you can foresee, Kopete displays everything perfectly, and so it does
now (not actually now, but it would if i run it).

I run gentoo and i try to stay to the stable tree as long as it doesn't
take me to install something weird. Anyway my xorg, xft and "the
Powerline" packages
are the following:
#x11-base/xorg-server-1.17.4 #x11-libs/libXft-2.3.2
#media-fonts/powerline-symbols-20150224
which in my current time are considered stable.
urxvt is 9.21 and something called 9.22 which is from unstable tree.
Both versions have exactly same behavior regarding the problem.

So the problem is with urxvt, or my configuration of urxvt.

My ~/.Xresources : http://pastebin.com/y8ivm56W

Probably you have already read, that in order for "the Powerline" to
work with urxvt it should be built with "unicode3" configuration, and
yes i did it http://pastebin.com/y8ivm56W .
I also downloaded rxvt-unicode sources and made a fresh build without
using gentoo portage system, just to check - it doesn't matter.

I tried specifying font to urxvt using the command line parameter, from
~/.Xresourses and ~/.Xdefaults files, and using the magic term-sequesnce.
I found out that urxvt is very reliable when it comes to using it's
various features.

I tried building urxvt with all sane USE-flag combination.

So, if anybody knows how to fix that - please help.
Meanwhile will try debugging~

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schmorp.de/pipermail/rxvt-unicode/attachments/20160109/62444c62/attachment.html>


More information about the rxvt-unicode mailing list