[rxvt-unicode] urxvt compiled against gcc 4.8.1 doesn't start

Marc Lehmann schmorp at schmorp.de
Mon Aug 19 09:14:42 CEST 2013


On Sun, Aug 18, 2013 at 12:50:38PM -0600, Javier Vasquez <j.e.vasquez.v at gmail.com> wrote:
> Actually the problem is that rxvt-unicode uses the username as owner
> and tty as group.  I think the easy approach is to include the user
> into the tty group, and that solves the problem.
> 
> For some reason when recompiling tty the permissions were lost.  I was
> not expecting that, :-)

> On the other hand  there are other approaches like chmod +s, and some
> others...  But I believe what I did before, and was lost with glibc
> recompilation, was being part of the tty group.

Let's assume then that the problme had nothing to do with compilation and
urxvt, but was an administrative error in setting up tty permissions.

> If there's a recommended way, please let me know...

On GNU/Linux, urxvt uses the posix functions to allocate ttys. Normally,
all the devices are dynamically created by udev and devpts, so if you
played around with that, you need to fix it. The recommended way is not to
play with the defaults :)

-- 
                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      schmorp at schmorp.de
      -=====/_/_//_/\_,_/ /_/\_\




More information about the rxvt-unicode mailing list