[PATCH] fix build error with automake-1.14, dnl comment need start at newline

Marc Lehmann schmorp at schmorp.de
Sun Dec 22 07:21:36 CET 2013


On Sun, Dec 22, 2013 at 08:44:22AM +0800, "Lan Yixun (dlan)" <dennis.yxun at gmail.com> wrote:
> with changes AM_INIT_AUTOMAKE, dnl trucate the end of trailing newline
> thus make next macro append to same line, result in weird error

I don't see anything related in these lines in our configure script - are
you sure you used the configure script that came with libev?

If you regenerate the configure script you need to use the exact same
version of automake as libev uses - unfortunately, automake doesn't have
much backwards or forwards compatibility, as you have seen.

As such, this looks like a bug needlessly introduced by gentoo (it doesn't
seem to exist in the pristine libev version). Please advise if this
analysis looks incorrect.

-- 
                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      schmorp at schmorp.de
      -=====/_/_//_/\_,_/ /_/\_\



More information about the libev mailing list