mingw-w64 null event loop

Marc Lehmann schmorp at schmorp.de
Thu Nov 21 15:26:25 CET 2013

On Thu, Nov 21, 2013 at 06:44:51PM +0900, Spoo <spoo at zarbosoft.com> wrote:
> I installed mingw-w64-gcc on Arch Linux (using the aur package). I configured libev with --host=x86_64-w64-mingw32 (no other configure flags except prefix). 
> In my code I try ev_default_loop(0) and then ev_new_loop(0) and both return null/0/false. Libev is static linked. I just tried it on a fresh windows 7 install and there are no env variables set relating to libev. It also fails on my old windows install and in wine. 

ev_default_loop returns 0 when none of the backend worked. since select
and poll always succeed, I guess those two backends are not compiled
in. What configure output do you get? Do you have the required header
files and working select/poll?

> I'd love to help try debugging this if you have any ideas where to start. 

Well, start your debugger and step through ev_default_loop, and see why it
returns 0 :)

                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      schmorp at schmorp.de
      -=====/_/_//_/\_,_/ /_/\_\

More information about the libev mailing list