Perl EV does not detect epoll on Debian 7+

Robert Norris rob at eatenbyagrue.org
Mon Jul 15 04:23:51 CEST 2013


On Mon, Jul 15, 2013 at 04:14:14AM +0200, Marc Lehmann wrote:
> Hmm, my debian wheezy ahs that file, but it's a compatibility symlink.

Seems to placed there during upgrade from squeeze/pre-multiarch. My new
wheezy machines don't have it. My laptop does.

> However, autodetection is always just a guess - the Makefile.PL asks
> you whether to enable epoll, so you can just answer "y" there.

Sure, unless you're using the "just take the defaults" option. Which
Debian's libev-perl does, and thus doesn't compile in epoll support.

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716928

I've got my own automatic build stuff to upgrade/workaround Debian build
bugs. The EV_EPOLL variable was useful there, otherwise I probably would
have had to patch something.



More information about the libev mailing list