Definition conflict: EV_ERROR
191919
191919 at gmail.com
Wed Feb 8 13:43:18 CET 2012
In ev.h, EV_ERROR is defined as an enum value:
EV_ERROR = 0x80000000 /* sent when an error occurs */
but in systems which have kqueue, EV_ERROR is defined for the use of kqueue itself:
/usr/include/sys/event.h:#define EV_ERROR 0x4000 /* error, data contains errno */
I suggest libev rename EV_ERROR to EV_EVERROR or something else.
--
191919
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schmorp.de/pipermail/libev/attachments/20120208/d095809a/attachment.html>
More information about the libev
mailing list