EV fails to install on OS X 10.7

Kulin Remailer remailer at reece.net.au
Sun Jan 22 14:59:14 CET 2012


Installing EV using cpanm on OS X 10.7 with Perl 5.14.2 fails. Installing manually

produces following error:

  In file included from EV.xs:35:

  libev/ev.c:924:3: error: #error "memory fences not defined for your architecture, please report".



Is Mac OS X unsupported? Searching this mailing list, I have seen several

comments that imply you don't want to support it. And there are a couple of

poor ratings on cpanratings saying EV has not been installable via CPAN

on Mac for quite a while.



If it's unsupported, could you please add something in the Pod so people

don't have to waste their time.





More information about the libev mailing list