libecb patch: fix compile warnings on gcc-llvm 4.2.1 (OS X 10.6 with Xcode 4)

Brandon Black blblack at gmail.com
Thu Dec 8 23:26:33 CET 2011


On Thu, Dec 8, 2011 at 4:18 PM, Hongli Lai <hongli at phusion.nl> wrote:
>
> I don't know whether it's fully implemented, but everything that ecb.h
> uses *is* fully implemented in llvm-gcc 4.2.1. This is pretty huge
> because Xcode 4 now uses llvm-gcc as the default gcc so all OS X users
> will get these warnings.
>
>
I doubt they're actually fully implemented in OSX's llvm-gcc 4.2.1.  Do you
have any supporting documentation or research on that?  Also the llvm-gcc
4.2.1 that OSX shipped with 4.2.1 was a pretty tragic mistake on their
part, IMHO.  It's a branch of code that upstream considers deprecated and
unsupported, and has known bugs.  See this bug link upstream:
http://llvm.org/bugs/show_bug.cgi?id=9891 .
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schmorp.de/pipermail/libev/attachments/20111208/321d8279/attachment.html>


More information about the libev mailing list