EV::MakeMaker order of includes

Yann Kerherve yann at cyberion.net
Tue Nov 23 05:51:38 CET 2010


Hi,

I've tried to install Feersum (which depends on EV) using cpanm
(+local::lib)

  $ cpanm -L . Feersum

but it fails because of an  incorrect include path:

cc -c  -I. -I/usr/local/lib/perl/5.10.1/EV -I/usr/local/lib/perl/5.10.1
-D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe
-fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2 -g   -DVERSION=\"1.000\" -DXS_VERSION=\"1.000\"
-fPIC "-I/usr/lib/perl/5.10/CORE"   Feersum.c
Feersum.xs: In function ‘prepare_cb’:
Feersum.xs:653: error: ‘EVBREAK_ALL’ undeclared (first use in this function)
...

Basically if finds an older system version of EV rather that the one
installed locally.

The following patch fixes it for me:

--- MakeMaker.pm        2010-10-25 06:35:17.000000000 -0700
+++ EV/MakeMaker.pm 2010-11-22 20:41:00.000000000 -0800
@@ -19,7 +19,7 @@
 $extra =~ s/$Config{prefix}/$opt{PREFIX}/ if
     exists $opt{PREFIX};

-for my $d ($extra, @INC) {
+for my $d (@INC, $extra) {
    if (-e "$d/EV/EVAPI.h") {
       $installsitearch = $d;
       last;

Feel free to direct me to proper bug report channel if appropriate,

Regards,

Yann
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schmorp.de/pipermail/libev/attachments/20101122/8e5da6ed/attachment.html>


More information about the libev mailing list