libev under QNX 6.3.2

Rodrigo Campos rodrigocc at gmail.com
Wed Jan 7 19:15:19 CET 2009


On Wed, Jan 7, 2009 at 3:55 PM, Marc Lehmann <schmorp at schmorp.de> wrote:
>> > when given the right include paths, this should now compile out of the box
>> > (at least w.r.t. ev_select.c).
>>
>> I've tried it, it fails with:
>
> oh right, my mistake.
>
>> Perhaps the problem is that gcc 2.95 is being used by default ? I've
>
> kind of - that part uses c99, which 2.95 doesn't support (and 3.3.5
> probably needs a switch, both ancient compilers).
>
> however, libev is supposed to compile even with c89 compilers.
>
> can you try this:
>
>   http://data.plan9.de/libev-3.51.tar.gz
>
> or simply comment out line 75 in ev_select.c (which is an assert).
>
> thanks!

Yes, it compiles ok! :)

>
>> And I run ./configure with the path gcc uses, but it fails to detect
>> poll.h too. I think the problem is that poll.h is under "sys" there
>> too.
>
> You have to configure the path where poll.h is to be found, not the path
> where sys/ is, as poll.h is the correct header.

How can I do that ? I didn't find a way to do it when I run
"./configure --help". Or is not on configure where I should do it ? I
really don't know :)

>
>> Please let me know if I can try something else to help debugging the problem :)
>
> keep on compiling and reporting, that's helping a lot :)

=)



Thanks a lot!

Rodrigo



More information about the libev mailing list