libev under QNX 6.3.2

Marc Lehmann schmorp at schmorp.de
Wed Jan 7 18:55:26 CET 2009


> > when given the right include paths, this should now compile out of the box
> > (at least w.r.t. ev_select.c).
> 
> I've tried it, it fails with:

oh right, my mistake.

> Perhaps the problem is that gcc 2.95 is being used by default ? I've

kind of - that part uses c99, which 2.95 doesn't support (and 3.3.5
probably needs a switch, both ancient compilers).

however, libev is supposed to compile even with c89 compilers.

can you try this:

   http://data.plan9.de/libev-3.51.tar.gz

or simply comment out line 75 in ev_select.c (which is an assert).

thanks!
   
> And I run ./configure with the path gcc uses, but it fails to detect
> poll.h too. I think the problem is that poll.h is under "sys" there
> too.

You have to configure the path where poll.h is to be found, not the path
where sys/ is, as poll.h is the correct header.

> Please let me know if I can try something else to help debugging the problem :)

keep on compiling and reporting, that's helping a lot :)

-- 
                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      pcg at goof.com
      -=====/_/_//_/\_,_/ /_/\_\



More information about the libev mailing list