libev under QNX 6.3.2

Rodrigo Campos rodrigocc at gmail.com
Wed Jan 7 17:11:56 CET 2009


On Tue, Jan 6, 2009 at 5:50 PM, Marc Lehmann <schmorp at schmorp.de> wrote:
> On Mon, Jan 05, 2009 at 01:09:31PM -0200, Rodrigo Campos <rodrigocc at gmail.com> wrote:
>> > I'll try to come up with a worksaorund that should compile out of the box in
>> > the next release (due soon).
>>
>> Cool, thanks a lot!
>
> Could you give:
>
>   http://data.plan9.de/libev-3.51.tar.gz
>
> when given the right include paths, this should now compile out of the box
> (at least w.r.t. ev_select.c).

I've tried it, it fails with:

/bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.
-g -O2 -O3 -c -o ev.lo `test -f 'ev.c' || echo './'`ev.c
 gcc -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -O3 -c ev.c  -fPIC -DPIC -o .libs/ev.o
In file included from ev.c:1223:
ev_select.c: In function `select_modify':
ev_select.c:80: parse error before `int'
ev_select.c:90: `handle' undeclared (first use in this function)
ev_select.c:90: (Each undeclared identifier is reported only once
ev_select.c:90: for each function it appears in.)
make[1]: *** [ev.lo] Error 1
make[1]: Leaving directory `/root/rata/libev/qnx/libev-3.51'
make: *** [all] Error 2

Perhaps the problem is that gcc 2.95 is being used by default ? I've
tried exporting CC to use gcc 3.3.5 but it failed the same way (I run
"CC='/usr/qnx632/host/qnx6/x86/usr/bin/ntox86-gcc-3.3.5' make", just
in case you need to know)

And I run ./configure with the path gcc uses, but it fails to detect
poll.h too. I think the problem is that poll.h is under "sys" there
too.


Please let me know if I can try something else to help debugging the problem :)



Thanks a lot,
Rodrigo



More information about the libev mailing list