libev under QNX 6.3.2

Marc Lehmann schmorp at schmorp.de
Mon Jan 5 11:25:56 CET 2009


On Sun, Jan 04, 2009 at 05:30:55PM -0200, Rodrigo Campos <rodrigocc at gmail.com> wrote:
> What I have to do to compile libev on QNX 6.3.2 is edit "configure"
> file and replace poll.h with sys/poll.h. QNX 6.3.2 (at least) does not
> include /usr/include it uses /usr/qnx632/target/qnx6/usr/include/ and
> poll is in "sys" there. I've checked in opengroup and the standard
> seems to be without "sys", so I guess this is a QNX bug.

You can fix thta simply by giving configure the corretc include path to
work with, no changes required.

> Then run ./configure and then edit config.h: I have to undef
> HAVE_SYS_SELECT_H and HAVE_SELECT (it fails to compile otherwise, I
> can send the error if you want, but I think its probably another QNX
> bug :)

Yes, that would be interesting, maybe it can be workarounded, in which
case it would work out of the box.

> Is there something else I could try to be sure that libev works OK on QNX ?

Not really - you'd probably run into more problems if you wanted to compile
more complicated programs for it.

-- 
                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      pcg at goof.com
      -=====/_/_//_/\_,_/ /_/\_\



More information about the libev mailing list