Error when configuring libeio

Marc Lehmann schmorp at schmorp.de
Mon Jun 9 16:13:25 CEST 2008


On Thu, Jun 05, 2008 at 08:51:23PM +0300, Paul Colomiets <pc at gafol.net> wrote:
> I'm getting this error, while configuring:
>   configure: error: cannot find install-sh or install.sh in "." "./.." 
> "./../.."
> 
> Bigger log below. Can anybody help me?

Yeha, follow the hints:

> libtoolize:   `/usr/share/aclocal/libtool.m4'
> libtoolize:   `/usr/share/aclocal/ltoptions.m4'
> libtoolize:   `/usr/share/aclocal/ltversion.m4'
> libtoolize:   `/usr/share/aclocal/ltsugar.m4'
> libtoolize:   `/usr/share/aclocal/lt~obsolete.m4'
> libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
> libtoolize: rerunning libtoolize, to keep the correct libtool macros 
> in-tree.
> libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
> /usr/share/aclocal/smpeg.m4:13: warning: underquoted definition of 
> AM_PATH_SMPEG
> /usr/share/aclocal/smpeg.m4:13:   run info '(automake)Extending aclocal'
> /usr/share/aclocal/smpeg.m4:13:   or see 
> http://sources.redhat.com/automake/automake.html#Extending-aclocal
> [pc at pc libeio]$ ./configure
> configure: error: cannot find install-sh or install.sh in "." "./.." 

You need an install (and working!) libtool, automake and autoconf to
configure the CVS tree.

-- 
                The choice of a       Deliantra, the free code+content MORPG
      -----==-     _GNU_              http://www.deliantra.net
      ----==-- _       generation
      ---==---(_)__  __ ____  __      Marc Lehmann
      --==---/ / _ \/ // /\ \/ /      pcg at goof.com
      -=====/_/_//_/\_,_/ /_/\_\



More information about the libev mailing list