[RFC] extending ev++.h to add C++ loop wrappers.

Leandro Lucarella llucax at gmail.com
Wed Jan 16 20:20:06 CET 2008

Leandro Lucarella, el 16 de enero a las 15:37 me escribiste:
> Marc Lehmann, el 16 de enero a las 05:43 me escribiste:
> > > > Maybe loop_simpel should rarlly be "loop" if we can get away with it
> > > > without collisions.
> > > 
> > > Yes, I thought about it too, but with all that "loop" everywhere I didn't
> > > thought it was a great idea (exactly because the high probability of
> > > colission ;). But once the patch is stabilized I can try to rename it to
> > > loop and see what happens...
> > 
> > Well, I think its a wonderful idea, its a loop, it should be called loop :)
> If we call it loop, then the loop() method has to be called other way,
> that's why I didn't call it loop. Maybe loop -> start, unloop -> stop
> (like watchers? but since they are radically different methods, maybe the
> must be called otherwise). Maybe just loop -> do_loop?

Even more, if we call it loop, then we can't name the internal base
watcher variable "loop" either :S

Leandro Lucarella (luca) | Blog colectivo: http://www.mazziblog.com.ar/blog/
GPG Key: 5F5A8D05 (F8CD F9A7 BF00 5431 4145  104C 949E BFB6 5F5A 8D05)
No es malo que en la condición humana exista la mentira. Miente el púber
si quiere ponerla.
	-- Ricardo Vaporeso. Madrid, 1921.

More information about the libev mailing list