[RFC] extending ev++.h to add C++ loop wrappers.

Leandro Lucarella llucax at gmail.com
Wed Jan 16 18:37:12 CET 2008

Marc Lehmann, el 16 de enero a las 05:43 me escribiste:
> > > Maybe loop_simpel should rarlly be "loop" if we can get away with it
> > > without collisions.
> > 
> > Yes, I thought about it too, but with all that "loop" everywhere I didn't
> > thought it was a great idea (exactly because the high probability of
> > colission ;). But once the patch is stabilized I can try to rename it to
> > loop and see what happens...
> Well, I think its a wonderful idea, its a loop, it should be called loop :)

If we call it loop, then the loop() method has to be called other way,
that's why I didn't call it loop. Maybe loop -> start, unloop -> stop
(like watchers? but since they are radically different methods, maybe the
must be called otherwise). Maybe just loop -> do_loop?

Leandro Lucarella (luca) | Blog colectivo: http://www.mazziblog.com.ar/blog/
GPG Key: 5F5A8D05 (F8CD F9A7 BF00 5431 4145  104C 949E BFB6 5F5A 8D05)
Es mejor probar el sabor de sapo y darse cuenta que es feo,
antes que no hacerlo y creer que es una gran gomita de pera.
	-- Dr Ricardo Vaporesso, Malta 1951

More information about the libev mailing list